• Help Support The Rugby Forum :

Using Proton or Wine to play EA Rugby 08 under Linux


Academy Player
Oct 9, 2007
Country Flag
South Africa
Club or Nation
Western Province
I created a thread to discuss using a gnu/linux based distro to play EA Rugby 08. I stopped using Windows as a daily driver a long time ago and currently using Ubuntu 20.04. I rarely have time to play so I sporadically mess around with Lutris/Wine/Proton.

Several years ago the game ran fine but my recent attempts failed at getting the game to run. I started writing an installer script for Rugby 08 using Lutris (https://lutris.net/games/rugby-08/) see the unpublished installer. The current roadblock is that when I try to install the game, Wine does not detect the Drive in the CD. I tested the install under a Windows 10 Virtual Machine and the game installs from the CD. This must be some configuration error on my side.

Using Proton: I haven't tried installing from Proton yet but I will try that. For a workaround, I copied the Windows installed folder into the "steam/steamapps/common" folder. I added the game as a non-steam game and forced the compatibility mode to use Proton experimental. I created a compatibility folder in the "steam/steamapps/compatdata" by copying a random compatdata into the folder. I set the game to launch in the compatdata folder. Clicking on 'Play' launches the game but it hangs before the video interlude. I suspect it is some codec missing. I will have to investigate which dll's or other requirements are needed.

If anyone else is using Linux feel free to expand in this thread.
Successfully launched EA Sports Rugby 08 adding it as a non-steam app and using proton.

The steps I followed, I copied my installed directory from a windows install to the "steam/steamapps/common" folder. I copied an existing compatdata to "steam/steamapps/compatdata". I used the "Rugby World Cup 2015" compatdata folder and I renamed it to "proton".

I then added the game exe as a non-steam app and set the target folder to the steam directory:
"~/steam/steamapps/common/EA SPORTS(TM) Rugby 08/Rugby08.exe"

I set the start in folder to the relevant directoy
"~/steam/steamapps/common/EA SPORTS(TM) Rugby 08/"

In compatibility mode I set the proton version to experimental.

The game did not launch so I tried to run proton via the terminal and link to the game by using the below command:

I used this post as a reference:

I first declared the compat directory in my bash using the below command
nano ~/.bashrc

I added the below lines at the bottom of the file
# Proton
export STEAM_COMPAT_DATA_PATH=~/games/steam/steamapps/compatdata/proton

I saved the file and restarted my machine

I then tried to run the game

"~/games/steam/steamapps/common/Proton - Experimental/proton" run "~/games/steam/steamapps/common/EA SPORTS(TM) Rugby 08/Rugby08.exe"

I saw an error relating to the fonts and install the missing freetype font:
"sudo apt install libfreetype6:i386"

If I use Steam to launch EA Sports Rugby 08 it launches and plays as per normal. I can save the profile.

Left to do:
Test to install the game from Steam.
Determine if it is the fonts or the modification to the bash that was the fix.
Determine where the game saves its files. It doesn't appear to be in the compatdata folder.
Test if the mods works.
Successfully installed the game from Steam as a non steam app

I have a separate drive for my Steam library, however Steam does not use this drive for the compatdata. The save files are stored in the compatdata in the home folder not in the separate library folder I created, even though it is set as the default library:
'~/.steam/steam/steamapps/compatdata' It creates a folder with a random number.

I successfully installed the game by adding the setup.exe as in the above process and ran the install setup. I will detail it in another post but basically the game is installed into the compatdata folder as described in the paragraph above. Steam creates a new compatdata folder.

Left to do:
Test if the mods works.
Hi i started with linux less than a year ago and i was wondering how you managed to run the game in ubuntu, theres partically nothing in the web about it, but this post. Can walk trough the steps you took whith detail. Cheers for the effort you put in to run the game in linux after so many years and sahred it.
@chrisNotAhston: Either my prior lack of knowledge or the recent advancements made it significantly easier to install the old EA Sports games. The three methods will be either using Wine directly; use Lutris (easier, especially if you can get the install script sorted); use Steam with Proton.

Steam with Proton requires a bit of manual pointing to directories during the install process and setting up the non Steam game but works very well. I also recently sucessfully got Rugby 06, Rugby 08 and Cricket 07 with and without mods working on the SteamDeck with very little effort. I had to setup a controller profile and it plays smoothly. When I have time I will document the steps in this thread. Just very pressed for time at work.

Latest posts