• Help Support The Rugby Forum :

Won’t launch


Academy Player
Aug 12, 2010
Country Flag

I have downloaded rugby 08 from various sites and no matter what I do it won't launch. I have tried different exe files and the one from the thread on here. Tried it in various compatibility modes and as an administrator. But it just won't start. The logo appears on the task bar then it disappears.

I have uninstalled it and deleted all the files and tried several clean installs.

Any ideas?

Mate, you tried adding the .exe to your anti virus's trusted program list?
i downloaded it from https://oldgamesdownload.com/rugby-08/ and it was the Rugby_08_Win_Files_EN.7z (1.0GB) which I then unzip with winrar. I then double click the exe and nothing happens. it appears briefly on the taskbar then disappears. Can anyone help?

Device name Laptop
Processor AMD Ryzen 7 5800H with Radeon Graphics 3.20 GHz
Installed RAM 16.0 GB (13.9 GB usable)
Device ID 2E046B98-C15D-4AE1-AF56-A2199668E0DE
Product ID 00342-20951-74833-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Edition Windows 11 Home
Version 22H2
Installed on ‎16/‎02/‎2023
OS build 22621.1992
Experience Windows Feature Experience Pack 1000.22644.1000.0
I don't have Windows 11 so can't give a direct answer, the only other suggestion would be to try changing settings in compatibility modes (Probably Windows XP would be best?), DPI scaling options, or running in Administrator mode.
It's image scaling options a the bottom of the compatibility menu, but I don't know if it will fix anything:


Latest posts