playing old games on vista

Discussion in 'General Gaming Chat' started by gingergenius, Jan 18, 2009.

  1. gingergenius

    gingergenius Guest

    Ok, for the sake of boredom with FM and GTA, and frustration with Rugby 08, I decided to spend my saturday morning with Age of Empires 2, since I havent played an rts for ages.

    Bloody thing doesn't work. I mean, the game works. I've done the compatability mode and all the rest of it. But for some reason there are lines across the screen... sort of colourful 'fuzz', instead of a picture. I can hear the background music and if I blindly stab around with my mouse, it's evident that I'm clicking on something. But the image is all screwed up.

    Can anyone help?
     
  2. Forum Ad Advertisement

  3. Bullitt

    Bullitt Guest

    Not just you, my flatmate allso attempted to play AoE2 on his Vista based laptop the other day and it wouldn't pay ball. There were similar issues with some older DOS based games when XP came along. Then again 'Black and White' works fine, so it may well be a case of pot luck at to what will and will not work.

    I'd suggest rolling back to XP and installing service pack 3; It's then got pretty much all the good features of Vista without the annoying tendancy to muller your processor. I'm also pretty certain AoE2 works with XP.
     
  4. munross

    munross Guest

    Well I've got Vista Home Premium 64-bit and AOE 2 and its expansion The Conquerors works perfectly fine without any problems...it also works on XP 100%.

    do you have the lastest drivers installed for your video card?
     
  5. gingergenius

    gingergenius Guest

    thanks...

    ok, somewhere in between task manager opening and my screen changing resolutions, a clear screen actually came up... once

    however the fonts didn't show up and so I was playing the game with no text (so I couldn't select which faction to play with; couldn't select the map/ difficulty/ game type etc.). Also, the grass was red & green and the mouse scrolling was jumpy.

    This was after I put on DirectX 9c, which apparently had direct draw or something that they took off v10.

    what are the latest video drivers? I've got GeForce 8400; don't know anything else.

    incidentally, Rugby 08 for me is f***ing slow and temperamental. Sometimes the game runs perfectly, other times it runs so that the try celebrations/ haka/ goalkicking etc. are really slow. Menus are also very jumpy. Why can it run fine some times and rubbish the rest of the time? Can't be overuse of my comp because there's 2GB of RAM hopping around.
     
  6. munross

    munross Guest

    Do you have a laptop or desktop pc?
     
  7. gingergenius

    gingergenius Guest

    <div class='quotetop'>QUOTE (Intercept King JdV @ Jan 18 2009, 12:39 PM) <{POST_SNAPBACK}></div>
    laptop
     
  8. dullonien

    dullonien Guest

    Go download and install the latest forceware drivers from the Nvidia website. Have a look if there is any patches for the game on the game developers website. Games usually do, for example a patch was needed for Max Payne 1 to work under Vista, but it still works.
     
  9. munross

    munross Guest

  10. gingergenius

    gingergenius Guest

    <div class='quotetop'>QUOTE (Intercept King JdV @ Jan 18 2009, 09:15 PM) <{POST_SNAPBACK}></div>
    cheers for your help buddy.
     
Enjoyed this thread? Register to post your reply - click here!

Share This Page