Rugby 08 PC - anyone have issues with Win7 (64bit)?

Discussion in 'EA Rugby 08' started by admartian, Jun 14, 2010.

  1. admartian

    admartian Senior Member

    Joined:
    Jul 2, 2009
    Messages:
    1,749
    Location:
    AKL
    Country Flag:

    New Zealand

    Club or Nation:

    New Zealand

    I've installed Rugby 08 on Windows 7 (64bit). Ir runs/installed fine, but during gameplay the actions fluctuate from players running slow.

    This will vary from game to game, where at one point it will be at 'normal' speed, then suddenly be going at about halfway to slow-mo pace.

    Anyone encounter this? If so did you fix it and how?
     
  2. Forum Ad Advertisement

  3. Woldog

    Woldog Senior Member

    Joined:
    Sep 23, 2008
    Messages:
    1,353
    Location:
    Gatton
    Country Flag:

    Australia

    Club or Nation:

    Reds

    It used to happen on my old PC, it may be your graphics card.
     
  4. FransBotes

    FransBotes Junior Member

    Joined:
    Apr 25, 2010
    Messages:
    23
    Location:
    South Africa
    Country Flag:

    South Africa

    Club or Nation:

    Lions

    Your system specs please?Try this out.
    As soon as you enter the game and want to play hit Ctrl ,Alt and Del. Choose task manager.
    Select the processes tab and search for Rugby 08.Right Click on it and select Set Affinity. Choose to use only one CPU.

    Hope this helps!
     
  5. Michaelwalsh

    Michaelwalsh Junior Member

    Joined:
    Sep 2, 2009
    Messages:
    26
    Country Flag:

    Ireland

    Club or Nation:

    Munster

    I have never been able to get the game to run on Windows 7 64 bit it just crashes at the startup screen. Strangely it manages Rugby 04 without any trouble.
     
    Last edited: Nov 30, 2010
  6. Enjay2008

    Enjay2008 Member

    Joined:
    Nov 24, 2008
    Messages:
    35
    Uninstall Rugby 2008, then insert your installation disk in the machine, Copy the contents to a temp folder right click on the copied setup.exe and select "Troubleshoot Compatibility" go through the wizard and save the gives you and run the application with those settings. It worked for me...
     
  7. TRF_Ezequiel

    TRF_Ezequiel Kanko Krazy!!!

    Joined:
    Jun 18, 2010
    Messages:
    7,239
    Location:
    Delft, Zuid-Holland, Netherlands
    Country Flag:

    Netherlands

    Club or Nation:

    Sharks

    Try to run it in Windows XP compatibilty mode

    - go to the shortcut, right click and go to 'properties'
    - go to the tab 'Compatibility'
    - Choose the option 'Run this program in compatibility mode for:'
    - Pick the option 'Windows XP (Service Pack 3)'

    Let me know
     
  8. Enjay2008

    Enjay2008 Member

    Joined:
    Nov 24, 2008
    Messages:
    35
    Also tick the "Run this program as an administrator" under the "Privledge level" on the Compatibility tab of the Rugby08.exe file...
     
Enjoyed this thread? Register to post your reply - click here!

Share This Page